Solved: WP Recent Posts: “Post-Plugin Library missing”

Some of you may have noticed the above message appearing where my recent posts should have been for the last week or two.  It turns out the “Post-Plugin Library missing” message can be fixed by downloading the latest copy of the Post-Plugin Library (shocking, I know).

I can’t remember if I upgraded WordPress or the Recent Posts plugin or both, but I’m guessing it was an upgrade to the Recent Post plugin that caused the problem.

The new version requires a “Post-Plugin library” (written by the same guy).

I found the link on my WordPress Admin Plugins page in the description of the Recent Posts plugin as part of a message telling me the plugin:

Requires the latest version of the Post-Plugin Library to be installed

Oops. Apparently I didn’t have any version of the Post-Plugin library and:

The Post-Plugin Library does nothing by itself but must be installed to provide shared code for the Similar Posts, Recent Posts, Random Posts> [sic], and Recent Comments plugins.

Author: nerd.

An experienced IT professional, I used to run a number of small websites and spend a lot of time tinkering with my sites or my PC - back when I had free time.

2 thoughts on “Solved: WP Recent Posts: “Post-Plugin Library missing””

Leave a Reply

Your email address will not be published. Required fields are marked *